Timeout Errors
Resolved
Aug 14 at 09:26am CDT
We have identified the root cause of the issue. All of our bots have remote logging using a third party platform so developers can debug without being on the same network as the server. Bots were attempting to send debug / info logs to the service and the service was refusing them. In each bots logic the bot is told that if there is an error it should log it, but it was attempting to log to the same third party service, overloading system resources causing bots to go offline and the api to degrade. All bots were switched to our backup servers within seconds of the incident ensuring no downtime for bots.
All services are back online, and all bots have been updated with the new error configurations. All bots and services are running on our main servers. We apologize for any inconvenience this may have caused.
Affected services
Updated
Aug 14 at 09:10am CDT
Our main servers are back up and running with all bots moved back. The root cause is still unknown and we are looking into it. More updates soon.
Affected services
Updated
Aug 14 at 08:54am CDT
Unknown cause, still investigating. Unknown if its a server or discord errror.
Affected services
Created
Aug 14 at 08:38am CDT
WilliamCloud main servers are unable to connect with discords gateways to make the bots online. All bots have been switched to our backup service pending investigation. More updates to come.
Affected services